-Ïîèñê ïî äíåâíèêó

Ïîèñê ñîîáùåíèé â rss_rss_linux_org_ru

 -Ïîäïèñêà ïî e-mail

 

 -Ïîñòîÿííûå ÷èòàòåëè

 -Ñòàòèñòèêà

Ñòàòèñòèêà LiveInternet.ru: ïîêàçàíî êîëè÷åñòâî õèòîâ è ïîñåòèòåëåé
Ñîçäàí: 24.08.2007
Çàïèñåé: 8221
Êîììåíòàðèåâ: 1
Íàïèñàíî: 1


Âûøåë RFC 9293: Transmission Control Protocol (TCP)

Âîñêðåñåíüå, 21 Àâãóñòà 2022 ã. 14:34 + â öèòàòíèê

Áîëåå ñîðîêà ëåò íàçàä, à èìåííî, â ñåíòÿáðå 1981 ãîäà, áûë óòâåðæäåí RFC 793, Transmission Control Protocol. Ýòîò ïðîòîêîë (â òî âðåìÿ - ñòàíäàðò Ìèíèñòåðñòâà Îáîðîíû ÑØÀ) îòâå÷àåò çà íàäåæíóþ äîñòàâêó ïîòîêîâ áàéò ìåæäó õîñòàìè â ñåòÿõ ñ êîììóòàöèåé ïàêåòîâ.  Èíòåðíåòå, îí ðàáîòàåò ïîâåðõ ïðîòîêîëà IP êàê ïðîòîêîë òðàíñïîðòíîãî óðîâíÿ. Ïîâåðõ íåãî óæå ðàáîòàþò ïðîòîêîëû óðîâíÿ ïðèëîæåíèé, òàêèå, êàê HTTP/1.1.

Çà âðåìÿ ñóùåñòâîâàíèÿ ñòàíäàðòà TCP â íåì áûëè îáíàðóæåíû ðàçëè÷íûå íåîäíîçíà÷íîñòè è íåäîðàáîòêè (íàïðèìåð, "ñèíäðîì áåñòîëêîâîãî îêíà"), äëÿ èñïðàâëåíèÿ êîòîðûõ áûëè ïðèíÿòû íîâûå RFC (íàïðèìåð, RFC 1122), óòî÷íÿþùèå èëè ÷àñòè÷íî èçìåíÿþùèå RFC 793. È, êîíå÷íî æå, ïðèíèìàëèñü RFC ñ èçìåíåíèÿìè è óëó÷øåíèÿìè, íå ëîìàþùèå ñîâìåñòèìîñòü - íàïðèìåð, RFC 1323 (íûíå çàìåíåííûé íà RFC 7323), îïèñûâàþùèé íîâûå îïöèè äëÿ ïîâûøåíèÿ ïðîèçâîäèòåëüíîñòè TCP íà áûñòðûõ êàíàëàõ ñ áîëüøîé çàäåðæêîé.

 èòîãå äëÿ ðàçðàáîò÷èêîâ, ðåàëèçóþùèõ ñòåêè ïðîòîêîëîâ TCP/IP (íàïðèìåð, äëÿ âñòðàèâàåìûõ ñèñòåì), ñëîæèëàñü íåïðèÿòíàÿ ñèòóàöèÿ, êîãäà ïðèõîäèòñÿ ñâåðÿòüñÿ íå ñ îäíèì äîêóìåíòîì, à ñ äåñÿòêàìè.  îêòÿáðå 2013 ãîäà áûëà íà÷àòà ðàáîòà ïî ïåðåïèñûâàíèþ ñòàíäàðòà TCP ñî âñåìè èñïðàâëåíèÿìè â âèäå îäíîãî äîêóìåíòà áåç èçìåíåíèÿ åãî ñìûñëà. Ïîñëå 35 ïðîìåæóòî÷íûõ ðåâèçèé, 18 àâãóñòà 2022 ãîäà â èòîãå ýòîé ðàáîòû áûë îïóáëèêîâàí îêîí÷àòåëüíûé äîêóìåíò, RFC 9293, îïðåäåëÿþùèé ìèíèìàëüíûé íàáîð ñîâðåìåííûõ ñïåöèôèêàöèé äëÿ ïðîòîêîëà TCP. Íåîáÿçàòåëüíûå ðàñøèðåíèÿ ïî-ïðåæíåìó îïðåäåëÿþòñÿ îòäåëüíûìè RFC.

, , ,

https://www.linux.org.ru/news/internet/16951923


 

Äîáàâèòü êîììåíòàðèé:
Òåêñò êîììåíòàðèÿ: ñìàéëèêè

Ïðîâåðêà îðôîãðàôèè: (íàéòè îøèáêè)

Ïðèêðåïèòü êàðòèíêó:

 Ïåðåâîäèòü URL â ññûëêó
 Ïîäïèñàòüñÿ íà êîììåíòàðèè
 Ïîäïèñàòü êàðòèíêó