-Ìåòêè

 -Ïîäïèñêà ïî e-mail

 

 -Ïîèñê ïî äíåâíèêó

Ïîèñê ñîîáùåíèé â CommandButton

 -Ñòàòèñòèêà

Ñòàòèñòèêà LiveInternet.ru: ïîêàçàíî êîëè÷åñòâî õèòîâ è ïîñåòèòåëåé
Ñîçäàí: 05.05.2008
Çàïèñåé:
Êîììåíòàðèåâ:
Íàïèñàíî: 214


Èñïîëüçîâàíèå ìåòàäàííûõ (HTTP-EQUIV, NAME, REL, REV, BASE) ïðè ñîçäàíèè HTML äîêóìåí

Ñðåäà, 01 Èþëÿ 2009 ã. 01:41 + â öèòàòíèê
Ìîíèñòà âñå çàïèñè àâòîðà

Îïèñàíèå è ôîðìàò ìåòà-òåãîâ HTML. Èñïîëüçîâàíèå ìåòàäàííûõ (HTTP-EQUIV, NAME, REL, REV, BASE) ïðè ñîçäàíèè HTML äîêóìåíòîâ.

META-òåãè èìåþò äâà âîçìîæíûõ àòðèáóòà

- <META HTTP-EQUIV="èìÿ" CONTENT="ñîäåðæèìîå">
- <META NAME="èìÿ" CONTENT="ñîäåðæèìîå">

META-òåãè äîëæíû íàõîäèòüñÿ â çàãîëîâêå HTML-äîêóìåíòà ìåæäó <HEAD> è </HEAD> (îñîáåííî ýòî âàæíî äëÿ äîêóìåíòîâ, èñïîëüçóþùèõ ôðåéìû).

 Àòðèáóò HTTP-EQUIV

 

META-òåãè ñ àòðèáóòîì HTTP-EQUIV ýêâèâàëåíòíû HTTP-çàãîëîâêàì. Îáû÷íî îíè óïðàâëÿþò äåéñòâèÿìè áðîóçåðîâ è ìîãóò áûòü èñïîëüçîâàíû äëÿ ñîâåðøåíñòâîâàíèÿ èíôîðìàöèè, âûäàâàåìîé îáû÷íûìè çàãîëîâêàìè. Òýãè òàêîé ôîðìû ìîãóò äàòü òàêîé æå ýôôåêò, ÷òî è HTTP-çàãîëîâêè, è íà íåêîòîðûõ ñåðâåðàõ àâòîìàòè÷åñêè ìîãóò áûòü ïåðåâåäåíû â íàñòîÿùèå HTTP-çàãîëîâêè. HTTP-çàãîëîâêè îïèñûâàþòñÿ â RFC1945 (HTTP/1.0) è RFC2068 (HTTP/1.1).

HTTP-çàãîëîâêè ìîãóò áûòü ñãåíåðèðîâàíû ñ ïîìîùüþ CGI-ñêðèïòîâ. Ýòî ïîçâîëÿþò ñäåëàòü ñåðâåðû Apache è CERN.  äðóãèõ ñåðâåðàõ ìîãóò èñïîëüçîâàòüñÿ äðóãèå ìåõàíèçìû ãåíåðèðîâàíèÿ çàãîëîâêîâ. Íåêîòîðûå ãåíåðèðóåìûå ñåðâåðîì ïîëÿ çàãîëîâêîâ íå ìîãóò áûòü ïîäìåíåíû çíà÷åíèÿìè èç META-òåãîâ (â ÷àñòíîñòè Date), äðóãèå ïîäìåíÿþòñÿ òîëüêî ïðè íåíîðìàëüíîì ñòàòóñ-êîäå (<>200). Êîãäà çàãîëîâîê íå ïîíÿòåí, òî çíà÷åíèå HTTP-çàãîëîâêà ïðåâàëèðóåò íàä çíà÷åíèåì META-òåãîâ.

Expires

 

Èñòî÷íèêè: HTTP/1.1 (RFC2068)

Äàòà óñòàðåâàíèÿ. Óïðàâëåíèå êýøèðîâàíèåì â HTTP/1.0.  Netscape Navigator ýòî âûãëÿäèò ñëåäóþùèì îáðàçîì: åñëè óêàçàííàÿ äàòà ïðîøëà, òî î÷åðåäíîé çàïðîñ ýòîãî html-äîêóìåíòà âûçûâàåò ïîâòîðíûé ñåòåâîé çàïðîñ, à íå ïîäãðóçêó html-äîêóìåíòà èç êýøà. Äàòà ñî çíà÷åíèåì "0" èíòåðïðåòèðóåòñÿ êàê "ñåé÷àñ". Òàêîå çíà÷åíèå çàñòàâëÿåò áðîóçåð êàæäûé ðàç ïðè çàïðîñå ïðîâåðÿòü - èçìåíÿëñÿ ëè ýòîò html-äîêóìåíò. Ýòî, êñòàòè îòíîñèòñÿ è ê ïðîêñè-àãåíòàì. Ïîèñêîâûå ðîáîòû ìîãóò ëèáî ñîâñåì íå èíäåêñèðîâàòü òàêîé äîêóìåíò, ëèáî ïîñòîÿííî "îáíþõèâàòü" åãî.

Äàòà äîëæíà áûòü çàäàíà â ôîðìàòå, îïèñûâàåìîì â RFC850,

<META HTTP-EQUIV="expires" CONTENT="Wed, 26 Feb 1997 08:21:57 GMT">

÷òî ýêâèâàëåíòíî HTTP-çàãîëîâêó

Expires: Wed, 26 Feb 1997 08:21:57 GMT

Pragma

Êîíòðîëü êýøèðîâàíèÿ äëÿ HTTP/1.0. Çíà÷åíèåì äîëæíî áûòü "no-cache". Î÷åíü ïîëåçíûé êîíòåéíåð, ÿ âñåãäà èñïîëüçóþ åãî ïðè âûäà÷å ðåçóëüòàòîâ ðàáîòû ëþáîãî ñêðèïòà.

Content-Type

Èñòî÷íèêè: HTTP/1.0 (RFC1045)

Óêàçàíèå òèïà html-äîêóìåíòà. Ìîæåò áûòü ðàñøèðåíî óêàçàíèåì êîäèðîâêè ñòðàíèöû (charset). Åñëè æå óêàçûâàòü charset â ñîäåðæàíèè META-òåãà, òî Netscape Navigator âûâîäèò òàêóþ html-ñòðàíèöó óæå â çàäàííîì charset. Îäíàêî áóäüòå àêêóðàòíû, åñëè òåêñò ñòðàíèöû â êîäèðîâêå Windows, à çíà÷åíèå charset=KOI8-r, òî íèêàêèìè ñèëàìè ïîëüçîâàòåëü íå ñìîæåò ïîìåíÿòü encoding, ÷òîáû óâèäåòü íîðìàëüíûå ñëîâà!

<META HTTP-EQUIV="Content-type" CONTENT="text/html; charset=ISO-2022-JP">

Content-language

Èñòî÷íèêè: HTTP/1.0

Óêàçàíèå ÿçûêà äîêóìåíòà. Ìîæåò èñïîëüçîâàòüñÿ ïîèñêîâûìè ìàøèíàìè ïðè èíäåêñèðîâàíèè html-ñòðàíèö. Êîìáèíàöèÿ ïîëÿ Accept-Language (ïîñûëàåìîãî áðîóçåðîì) ñ ñîäåðæèìûì Content-language ìîæåò áûòü óñëîâèåì âûáîðà ñåðâåðîì òîãî èëè èíîãî ÿçûêà.

<META HTTP-EQUIV="Content-language" CONTENT="en-GB">

÷òî ýêâèâàëåíòíî HTTP-çàãîëîâêó

 íåäàâíî âûøåäøåé ñïåöèôèêàöèè HTML 4.0 ïîÿâèëàñü äðóãàÿ âîçìîæíîñòü ÿâíîãî óêàçàíèÿ ÿçûêà - <html lang="en">

Content-language: en-GB

ßçûê îïèñûâàåòñÿ ïàðîé çíà÷åíèé (ÿçûê-äèàëåêò).  ïðèìåðå: Àíãëèéñêèé-Âåëèêîáðèòàíèÿ

Refresh

Èñòî÷íèêè: Netscape

Îïðåäåëåíèå çàäåðæêè â ñåêóíäàõ, ïîñëå êîòîðîé áðîóçåð àâòîìàòè÷åñêè îáíîâëÿåò html-äîêóìåíò. Äîïîëíèòåëüíàÿ âîçìîæíîñòü - àâòîìàòè÷åñêàÿ çàãðóçêà äðóãîãî äîêóìåíòà.

<META HTTP-EQUIV="Refresh" Content="3, URL=http://www.name.com/page.html">

÷òî ýêâèâàëåíòíî HTTP-çàãîëîâêó

Refresh: 3; URL=http://www.name.com/page.html

 Netscape Navigator ýòî äàåò òàêîé æå ýôôåêò, ÷òî è íàæàòèå íà êíîïêó Reload.

Window-target

Èñòî÷íèêè: Jahn Rentmeister

Îïðåäåëÿåò îêíî òåêóùåé ñòðàíèöû; ìîæåò áûòü èñïîëüçîâàí äëÿ ïðåêðàùåíèÿ ïîÿâëåíèÿ íîâûõ îêîí áðîóçåðà ïðè ïðèìåíåíèè ôðåéìîâûõ ñòðóêòóð. Äåéñòâóåò äëÿ ìíîãèõ (íî íå äëÿ âñåõ) áðîóçåðîâ.

<META HTTP-EQUIV="Window-target" CONTENT="_top">

÷òî ýêâèâàëåíòíî HTTP-çàãîëîâêó

Window-target: _top

Ext-cache

Èñòî÷íèêè: Netscape

Îïðåäåëÿåò èìÿ àëüòåðíàòèâíîãî êýøà äëÿ Netscape Navigator

<META HTTP-EQUIV="Ext-cache" CONTENT="name=/some/path/index.db; istructions=User Instructions">

PICS-Label

Platform-Independant Content rating Scheme. Îáû÷íî èñïîëüçóåòñÿ äëÿ îïðåäåëåíèÿ ðåéòèíãà "âçðîñëîñòè" (adult) ñîäåðæàíèÿ (sex,violence, ...):-)) îäíàêî ýòî äîâîëüíî ãèáêàÿ ñõåìà è ìîæåò èñïîëüçîâàòüñÿ äëÿ äðóãèõ öåëåé.

Cache-Control

Èñòî÷íèêè: HTTP/1.1

Îïðåäåëÿåò äåéñòâèÿ êýøà ïî îòíîøåíèþ ê äàííîìó html-äîêóìåíòó. Âîçìîæíûå çíà÷åíèÿ:

  • Public - äîêóìåíò êýøèðóåòñÿ â äîñòóïíûõ äëÿ âñåõ êýøàõ
  • Private - òîëüêî â ÷àñòíîì êýøå
  • no-cache - íå ìîæåò áûòü êýøèðîâàí
  • no-store - ìîæåò áûòü êýøèðîâàí, íî íå ñîõðàíÿåòñÿ

Vary

Èñòî÷íèêè: HTTP/1.1

Îïðåäåëÿåò äîñòóïíûå àëüòåðíàòèâû äëÿ óêàçàííûõ â CONTENT ïîëåé HTTP-çàãîëîâêà.

<META HTTP-EQUIV="Vary" CONTENT="Content-language">

÷òî ýêâèâàëåíòíî HTTP-çàãîëîâêó

Vary: Content-language

Lotus

Lotus-ðåäàêòîðû ãåíåðèðóþò ñâîè ñîáñòâåííûå ïîëÿ Bulletin-Date è Bulletin-Text àòðèáóòû. Bulletin-Text ñîäåðæèò îïèñàíèå äîêóìåíòà

Ðóáðèêè:  ïðîãðàììèðîâàíèå
ñîâåòû
HTML

 

Äîáàâèòü êîììåíòàðèé:
Òåêñò êîììåíòàðèÿ: ñìàéëèêè

Ïðîâåðêà îðôîãðàôèè: (íàéòè îøèáêè)

Ïðèêðåïèòü êàðòèíêó:

 Ïåðåâîäèòü URL â ññûëêó
 Ïîäïèñàòüñÿ íà êîììåíòàðèè
 Ïîäïèñàòü êàðòèíêó