Случайны выбор дневника Раскрыть/свернуть полный список возможностей


Найдено 3139 сообщений
Cообщения с меткой

таблицы - Самое интересное в блогах

Следующие 30  »
rss_rss_hh_new

Размещение таблицы значений с помощью доп реквизита и расширения конфигурации 1С

Суббота, 24 Сентября 2016 г. 23:55 (ссылка)

Меня очень часто спрашивают, как добавить таблицу к документу или справочнику?

И действительно, как сделать такую задачу не усложняя дальнейшее обновление конфигурации? И вроде есть доп. реквизиты и доп. сведения, но почему же они не могут принимать тип таблицы значений?




В итоге чаще всего используется 2 варианта:



1. Простой способ. Прямо в объекте добавляется таблица, а затем либо программно либо жестко(вручную) выводится на форму.

Минусы. Обновление конфигурации будет требовать соблюдения изменений и повышенной внимательности, чтобы не потерять эти изменения.

Плюсы. Самый простой вариант для разработки, к таблице значений можно обращаться без танцев с бубном, например через запросы.


2. Нормальный вариант, но тоже с доработкой конфигурации.

Добавляется объект с таблицей значений и реквизитом содержащий объект родитель, данная таблица значений выводится, к примеру, через расширение конфигурации на форму основного объекта.

Плюсы. Простое обновление, к таблице значений можно обращаться, например через запросы.

Минусы. Требуется больше предусмотреть различные ограничения на созданный объект а, следовательно, требует определенных знаний. Возможно, потребуется добавление роли\ей и настройки профилей пользователей.


Есть, конечно, еще другие варианты к примеру с хранилищем, но статья не об этом…



Статья, о том, как все-таки хранить таблицу значений в доп. реквизитах, ну или в доп. сведениях.



Уже более полугода держу в голове этот способ, но ни разу его не применял. Вот, наконец, добрались руки. Я не утверждаю, что никто не придумывал данный способ, но на подобное решение я не натыкался. Заранее скажу, вариант не идеален, и сгодится только под определенные задачи.



Самый главный минус это то, что будет использоваться строка неограниченной длины а, следовательно, с поиском в ней будут определенные сложности. Самый главный плюс, объекты в конфигурации не правятся.



Пример продемонстрирую на конфигурации Документооборот 2.1.6.8. Буду использовать дополнительный реквизит, но можно использовать дополнительные сведения. Весь код будет написан в Расширении конфигурации.



Задача:

Сразу говорю задачка больше шуточная для демонстрации метода. Например, нам понадобилось добавить табличную часть «Адекватность контактных лиц», она должна присутствовать в справочнике Контрагенты и содержать колонки: Контактное лицо, Совет (некая рекомендация по общению с контактным лицом), Тип контакта.



1 Добавляем доп. реквизит и называем его к примеру «ТЗ_АдекватностьКонтактныхЛиц».

Я этот реквизит делаю общим для всех видов контрагентов. Тип его будет строка неограниченной длины.







2 Создаем Расширение конфигурации и Дорабатываем форму Контрагентов.

Добавляем реквизиты формы:



— «ДопТЗ» тип ПланВидовХарактеристикСсылка.ДополнительныеРеквизитыИСведения

— ТЗ_АдекватностьКонтактныхЛиц тип ТаблицаЗначений:

КонтактноеЛицо тип СправочникСсылка.КонтактныеЛица

ТипКонтакта тип Строка

Совет тип Строка







Добавляем на форму страницу «ГруппаАдекватностьКонтактныхЛиц» и снимаем видимость.

В данную группу выводим «ТЗ_АдекватностьКонтактныхЛиц»







3 Пишем код.

ПриСозданииНаСервере.
Необходимо считать сам доп реквизит напомню мы его обозвали «ТЗ_АдекватностьКонтактныхЛиц», далее прочитать его значение и построить по его значению таблицу значений.



Значение доп реквизита я предлагаю хранить в формате JSON, у кого более старая платформа можно использовать XML.



Процедура ДопТЗ_ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//Считываем доп реквизит
//ТЗ_АдекватностьКонтактныхЛиц - В моем примере доп реквизит называется так
ДопТЗ = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ТЗ_АдекватностьКонтактныхЛиц");

Если ЗначениеЗаполнено(ДопТЗ) Тогда
//Если нашли свойство тогда делаем страницу с ТЗ видимой
Элементы.ГруппаАдекватностьКонтактныхЛиц.Видимость = Истина;

//Считываем значение доп реквизита
НайденныеСтроки = Объект.ДополнительныеРеквизиты.НайтиСтроки(Новый Структура("Свойство", ДопТЗ));
перЗначение = ?(НайденныеСтроки.Количество() = 1, НайденныеСтроки[0].Значение, Неопределено);

//Если значение прочитали пытаемся прочитать из JSON
Если перЗначение <> Неопределено Тогда
//Читаем JSON
ЧтениеJSON = Новый ЧтениеJSON;
ЧтениеJSON.УстановитьСтроку(перЗначение);
Попытка
ДопДанные = ПрочитатьJSON(ЧтениеJSON);
Исключение
ДопДанные = "";
КонецПопытки;
//Если вернулся массив значит JSON прочитали нормально
//Заполняем ТЗ_АдекватностьКонтактныхЛиц
Если ТипЗнч(ДопДанные) = Тип("Массив") Тогда
Для Каждого СтрокаДД из ДопДанные Цикл
СтрАдекватов = ТЗ_АдекватностьКонтактныхЛиц.Добавить();
//Мы уже зарание знаем какой элемент нужно искать по уникальному идентификатору
СтрАдекватов.КонтактноеЛицо = ПолучитьСсылкуПоGUIDИВидуОбъекта(СтрокаДД.КонтактноеЛицо,"Справочники.КонтактныеЛица");
СтрАдекватов.ТипКонтакта = СтрокаДД.ТипКонтакта;
СтрАдекватов.Совет = СтрокаДД.Совет;
КонецЦикла;
КонецЕсли;

КонецЕсли;
КонецЕсли;

КонецПроцедуры

//Функция возврата Ссылки по уникальному идентификатору и виду объекта
&НаСервере
Функция ПолучитьСсылкуПоGUIDИВидуОбъекта(GUIDВх,ВидОбъектаВх) Экспорт
Результат=Неопределено;
Попытка
Выполнить("Результат = "+ВидОбъектаВх+".ПолучитьСсылку(Новый УникальныйИдентификатор("""+GUIDВх+"""));");
Исключение
КонецПопытки;
Возврат Результат;
КонецФункции




ПриОткрытии. Программно прячем доп. реквизит. Он хранит JSON, поэтому пользователю особо неинтересен.



&НаКлиенте
Процедура ДопТЗ_ПриОткрытии(Отказ)
Если ЗначениеЗаполнено(ДопТЗ) Тогда
//Ищем на форме нужный нам доп реквизит
//Свойства_ОписаниеДополнительныхРеквизитов - В документообороте, в других конфигурациях скорее всего по другому.
НайденныеСтроки = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(Новый Структура("Свойство", ДопТЗ));
//Прячем элемент программно
Если НайденныеСтроки.Количество() = 1 Тогда
Элементы[НайденныеСтроки[0].ИмяРеквизитаЗначение].Видимость = Ложь;
КонецЕсли;
КонецЕсли;
КонецПроцедуры


ПередЗаписьюНаСервере. Если ТЗ изменилась сохраняем ее в виде строки JSON в доп. реквизит.



Процедура ДопТЗ_ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЗначениеЗаполнено(ДопТЗ) Тогда
//Свойства_ОписаниеДополнительныхРеквизитов - В документообороте, в других конфигурациях скорее всего по другому.
НайденныеСтроки = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(Новый Структура("Свойство", ДопТЗ));

//Описываем параметры записи и создаем запись JSON
ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, " " , Истина, ЭкранированиеСимволовJSON.Нет, Ложь, Ложь, Ложь, Ложь);
ЗаписьJSON = Новый ЗаписьJSON;
ЗаписьJSON.ПроверятьСтруктуру = Истина;
ЗаписьJSON.УстановитьСтроку(ПараметрыJSON);
//Создаем массив структур на основании ТЗ_АдекватностьКонтактныхЛиц
МассивАдекватов = Новый Массив;
Для Каждого СтрокаТЗ из ТЗ_АдекватностьКонтактныхЛиц Цикл
МассивАдекватов.Добавить(Новый Структура("КонтактноеЛицо,ТипКонтакта,Совет",
Строка(СтрокаТЗ.КонтактноеЛицо.УникальныйИдентификатор()),
СтрокаТЗ.ТипКонтакта,
СтрокаТЗ.Совет));

КонецЦикла;
//Записываем массив виде строки JSON
ЗаписатьJSON(ЗаписьJSON, МассивАдекватов);
СтрокаJSON = ЗаписьJSON.Закрыть();

//Если ТЗ изменили записываем новое значение доп реквизита
Если ЭтаФорма[НайденныеСтроки[0].ИмяРеквизитаЗначение] <> СтрокаJSON Тогда
ЭтаФорма[НайденныеСтроки[0].ИмяРеквизитаЗначение] = СтрокаJSON;
КонецЕсли;
КонецЕсли;
КонецПроцедуры



Original source: habrahabr.ru.

https://habrahabr.ru/post/310930/?utm_source=habrahabr&utm_medium=rss&utm_campaign=best

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
rss_rss_hh_new

Размещение таблицы значений с помощью доп реквизита и расширения конфигурации 1с

Суббота, 24 Сентября 2016 г. 23:55 (ссылка)

Меня очень часто спрашивают, как добавить таблицу к документу или справочнику?

И действительно, как сделать такую задачу не усложняя дальнейшее обновление конфигурации?

И вроде есть доп. реквизиты и доп. сведения, но почему же они не могут принимать тип таблицы значений?




В итоге чаще всего используется 2 варианта:

1 Простой способ. Прямо в объекте добавляется таблица, а затем либо программно либо жестко(вручную) выводится на форму.

Минусы. Обновление конфигурации будет требовать соблюдения изменений и повышенной внимательности, чтобы не потерять эти изменения.

Плюсы. Самый простой вариант для разработки, к таблице значений можно обращаться без танцев с бубном, например через запросы.



2 Нормальный вариант, но тоже с доработкой конфигурации.

Добавляется объект с таблицей значений и реквизитом содержащий объект родитель, данная таблица значений выводится, к примеру, через расширение конфигурации на форму основного объекта.

Плюсы. Простое обновление, к таблице значений можно обращаться, например через запросы.

Минусы. Требуется больше предусмотреть различные ограничения на созданный объект а, следовательно, требует определенных знаний. Возможно, потребуется добавление роли\ей и настройки профилей пользователей.



Есть, конечно, еще другие варианты к примеру с хранилищем, но статья не об этом…



Статья, о том, как все-таки хранить таблицу значений в доп. реквизитах, ну или в доп. сведениях.

Уже более полугода держу в голове этот способ, но ни разу его не применял. Вот, наконец, добрались руки. Я не утверждаю, что никто не придумывал данный способ, но на подобное решение я не натыкался. Заранее скажу, вариант не идеален, и сгодится только под определенные задачи.

Самый главный минус это то, что будет использоваться строка неограниченной длины а, следовательно, с поиском в ней будут определенные сложности.

Самый главный плюс, объекты в конфигурации не правятся.



Пример продемонстрирую на конфигурации Документооборот 2.1.6.8.

Буду использовать дополнительный реквизит, но можно использовать дополнительные сведения.

Весь код будет написан в Расширении конфигурации.



Задача:

Сразу говорю задачка больше шуточная для демонстрации метода.

Например, нам понадобилось добавить табличную часть «Адекватность контактных лиц», она должна присутствовать в справочнике Контрагенты и содержать колонки: Контактное лицо, Совет(некая рекомендация по общению с контактным лицом), Тип контакта.




1 Добавляем доп. реквизит и называем его к примеру «ТЗ_АдекватностьКонтактныхЛиц».

Я этот реквизит делаю общим для всех видов контрагентов.

Тип его будет строка неограниченной длины.







2 Создаем Расширение конфигурации и Дорабатываем форму Контрагентов.

Добавляем реквизиты формы:

-«ДопТЗ» тип ПланВидовХарактеристикСсылка.ДополнительныеРеквизитыИСведения

-ТЗ_АдекватностьКонтактныхЛиц тип ТаблицаЗначений:

КонтактноеЛицо тип СправочникСсылка.КонтактныеЛица

ТипКонтакта тип Строка

Совет тип Строка







Добавляем на форму страницу «ГруппаАдекватностьКонтактныхЛиц» и снимаем видимость.

В данную группу выводим «ТЗ_АдекватностьКонтактныхЛиц»







3 Пишем код.

ПриСозданииНаСервере.
Необходимо считать сам доп реквизит напомню мы его обозвали «ТЗ_АдекватностьКонтактныхЛиц», далее прочитать его значение и построить по его значению таблицу значений.

Значение доп реквизита я предлагаю хранить в формате JSON, у кого более старая платформа можно использовать XML.



Процедура ДопТЗ_ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
//Считываем доп реквизит
//ТЗ_АдекватностьКонтактныхЛиц - В моем примере доп реквизит называется так
ДопТЗ = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ТЗ_АдекватностьКонтактныхЛиц");

Если ЗначениеЗаполнено(ДопТЗ) Тогда
//Если нашли свойство тогда делаем страницу с ТЗ видимой
Элементы.ГруппаАдекватностьКонтактныхЛиц.Видимость = Истина;

//Считываем значение доп реквизита
НайденныеСтроки = Объект.ДополнительныеРеквизиты.НайтиСтроки(Новый Структура("Свойство", ДопТЗ));
перЗначение = ?(НайденныеСтроки.Количество() = 1, НайденныеСтроки[0].Значение, Неопределено);

//Если значение прочитали пытаемся прочитать из JSON
Если перЗначение <> Неопределено Тогда
//Читаем JSON
ЧтениеJSON = Новый ЧтениеJSON;
ЧтениеJSON.УстановитьСтроку(перЗначение);
Попытка
ДопДанные = ПрочитатьJSON(ЧтениеJSON);
Исключение
ДопДанные = "";
КонецПопытки;
//Если вернулся массив значит JSON прочитали нормально
//Заполняем ТЗ_АдекватностьКонтактныхЛиц
Если ТипЗнч(ДопДанные) = Тип("Массив") Тогда
Для Каждого СтрокаДД из ДопДанные Цикл
СтрАдекватов = ТЗ_АдекватностьКонтактныхЛиц.Добавить();
//Мы уже зарание знаем какой элемент нужно искать по уникальному идентификатору
СтрАдекватов.КонтактноеЛицо = ПолучитьСсылкуПоGUIDИВидуОбъекта(СтрокаДД.КонтактноеЛицо,"Справочники.КонтактныеЛица");
СтрАдекватов.ТипКонтакта = СтрокаДД.ТипКонтакта;
СтрАдекватов.Совет = СтрокаДД.Совет;
КонецЦикла;
КонецЕсли;

КонецЕсли;
КонецЕсли;

КонецПроцедуры

//Функция возврата Ссылки по уникальному идентификатору и виду объекта
&НаСервере
Функция ПолучитьСсылкуПоGUIDИВидуОбъекта(GUIDВх,ВидОбъектаВх) Экспорт
Результат=Неопределено;
Попытка
Выполнить("Результат = "+ВидОбъектаВх+".ПолучитьСсылку(Новый УникальныйИдентификатор("""+GUIDВх+"""));");
Исключение
КонецПопытки;
Возврат Результат;
КонецФункции




ПриОткрытии. Программно прячем доп. реквизит. Он хранит JSON, поэтому пользователю особо неинтересен.



&НаКлиенте
Процедура ДопТЗ_ПриОткрытии(Отказ)
Если ЗначениеЗаполнено(ДопТЗ) Тогда
//Ищем на форме нужный нам доп реквизит
//Свойства_ОписаниеДополнительныхРеквизитов - В документообороте, в других конфигурациях скорее всего по другому.
НайденныеСтроки = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(Новый Структура("Свойство", ДопТЗ));
//Прячем элемент программно
Если НайденныеСтроки.Количество() = 1 Тогда
Элементы[НайденныеСтроки[0].ИмяРеквизитаЗначение].Видимость = Ложь;
КонецЕсли;
КонецЕсли;
КонецПроцедуры




ПередЗаписьюНаСервере. Если ТЗ изменилась сохраняем ее в виде строки JSON в доп. реквизит.

Процедура ДопТЗ_ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЗначениеЗаполнено(ДопТЗ) Тогда
//Свойства_ОписаниеДополнительныхРеквизитов - В документообороте, в других конфигурациях скорее всего по другому.
НайденныеСтроки = ЭтаФорма.Свойства_ОписаниеДополнительныхРеквизитов.НайтиСтроки(Новый Структура("Свойство", ДопТЗ));

//Описываем параметры записи и создаем запись JSON
ПараметрыJSON = Новый ПараметрыЗаписиJSON(ПереносСтрокJSON.Нет, " " , Истина, ЭкранированиеСимволовJSON.Нет, Ложь, Ложь, Ложь, Ложь);
ЗаписьJSON = Новый ЗаписьJSON;
ЗаписьJSON.ПроверятьСтруктуру = Истина;
ЗаписьJSON.УстановитьСтроку(ПараметрыJSON);
//Создаем массив структур на основании ТЗ_АдекватностьКонтактныхЛиц
МассивАдекватов = Новый Массив;
Для Каждого СтрокаТЗ из ТЗ_АдекватностьКонтактныхЛиц Цикл
МассивАдекватов.Добавить(Новый Структура("КонтактноеЛицо,ТипКонтакта,Совет",
Строка(СтрокаТЗ.КонтактноеЛицо.УникальныйИдентификатор()),
СтрокаТЗ.ТипКонтакта,
СтрокаТЗ.Совет));

КонецЦикла;
//Записываем массив виде строки JSON
ЗаписатьJSON(ЗаписьJSON, МассивАдекватов);
СтрокаJSON = ЗаписьJSON.Закрыть();

//Если ТЗ изменили записываем новое значение доп реквизита
Если ЭтаФорма[НайденныеСтроки[0].ИмяРеквизитаЗначение] <> СтрокаJSON Тогда
ЭтаФорма[НайденныеСтроки[0].ИмяРеквизитаЗначение] = СтрокаJSON;
КонецЕсли;
КонецЕсли;
КонецПроцедуры





Original source: habrahabr.ru (comments, light).

https://habrahabr.ru/post/310930/

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
NetFact

Базовый Excel для интернет маркетинга (2016) Видеокурс » NetFact.Ru: Скачать бесплатно – Популярная Интернет Библиотека

Среда, 21 Сентября 2016 г. 14:20 (ссылка)
netfact.ru/videotech/3278-b...okurs.html


Базовый Excel для интернет маркетинга (2016) Видеокурс




Необходимые знания для уверенного владения и работы в MS Excel для аналитиков и интернет-маркетологов.

Вы научитесь:

-Обрабатывать и анализировать данные

-Оптимизировать бюджеты на рекламу

-Визуализировать результаты анализа

-Эффективно использовать Excel



Программа курса:



1. Базовые возможности Excel

*Приемы работы с интерфейсом и его настройки для себя

*Наиболее часто используемые формулы



- ЕСЛИ, СУММЕСЛИ, ЕСЛИОШИБКА

— ВПР, ИНДЕКС, ПОИСКПОЗ

— ЛЕВСИМВ, ПРАВСИМВ



*Часто используемые функции Excel и их горячие клавиши

— Вставка, специальная вставка и ее возможности

— “Перейти” (go to)



*Используем шаблоны документов от Microsoft

*Встроенные таблицы

*Моделирование KPI рекламных кампаний

*Разбор алгоритма работы VCG-аукциона в Excel

*Работа с фильтрами и расширенными фильтрами

*Разбор функций Excel на примере продвинутого разметчика Utm-меток

*Текстовые фукции для работы с семантическим ядром

— Формирование текстов на основе данных



2. Базовые возможности сводных таблиц

*Лучшие практики организации данных в MS Excel для удобного анализа

— Именуем ячейки и диапазоны и работаем с ними в формулах

— Как расположить данные на листах для удобной работы

*Умные таблицы и их использование

*Интерфейс сводных таблиц, варианты представления данных, настройки сводных таблиц

*Принцип Паретто в действии и его применение в сводных таблицах (группировка в таблицах)

*Описательная статистика с использованием сводных таблиц

— Подсчет количества значений, суммы, среднего и т.д.

*Различные калькуляции

*Процент по столбцу, по строке, прирост и т.д.

*Анализ статистических рекламных выгрузок в сводных таблицах

— Поиск и анализ неэффективных кампаний

*Работа с CSV выгрузками

*Создание дополнительных вычисляемых полей (CPO, AOV, GMV, Profit, Take Rate)

*ВПР без ограничений поиска по левому столбцу



3. Продвинутые возможности сводных таблиц

*Расчетные метрики и их использование

*Приемы работы с временными рядами

*Ассоциативные таблицы, связывание таблиц — строим базы данных внутри Excel

*Малоизвестные возможности сводных таблиц

*Приемы для анализа контекстной рекламы

*Практики группировки и вычисления для работы с контекстной рекламой



4. Визуализация данных

*Принципы визуализации — какие данные как визуализировать

*Подготовка данных для визуализации — как расположить данные в таблицах для использования в графиках

*Условное форматирование и возможности его использования (тепловая карта, фильтрация форматирования)

*Спарклайны

*Приемы работы с графиками внутри Excel

*Тонкости и хаки различных визуализаций







Базовый Excel для интернет маркетинга (2016) Видеокурс



Базовый Excel для интернет маркетинга (2016) Видеокурс



Базовый Excel для интернет маркетинга (2016) Видеокурс






Информация о видеокурсе

Название: Базовый Excel для интернет маркетинга

Автор: Максим Уваров

Год выхода: 2016

Жанр: Видеокурс

Язык: Русский

Выпущено: Россия

Продолжительность: ~18 часов



Файл

Формат: MP4

Видео: AVC, 1152x720, ~740 Kbps

Аудио: AAC, 235 Kbps, 48.0 KHz

Размер: 6.81 Gb



Скачать: Базовый Excel для интернет маркетинга (2016) Видеокурс



Скачать | Download | TurboBit.net

http://turbobit.net/0x5re40ena44/Bazovi_Excel_Dlya_Marketinga.rar.html



Скачать | Download | HitFile.net

http://www.hitfile.net/PNwUYDk/Bazovi_Excel_Dlya_Marketinga.rar.html



Скачать | Download | Файлообменник.рф

http://файлообменник.рф/z2zg56pc20qr/Bazovi_Excel_Dlya_Marketinga.rar.html

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
rss_barguzin

Эта таблица поможет быстро удалять пятна

Среда, 21 Сентября 2016 г. 09:04 (ссылка)

Чем удалять пятна с дивана, а также с кожаных изделий, уже давно будоражащий вопрос для многих людей. Составил для вас табличку, с помощью которой можно будет довольно просто найти ответ на вопрос, как вывести пятна различного происхождения.

Нужно будет довольно точно дать для себя ответ, что это за пятна. От этого сильно зависит успех при выведении пятен.

Итак!

3509984_himchistkadivanakiev1024x666 (700x455, 63Kb)

Источник пятна Способы сведения пятна
1 Грязь, пятна на мебельной коже, белом кожаном диване Развести в 1/2 стакана молока 1 яйцо, протереть влажной салфеткой диван, въевшаяся грязь исчезнет.
2 Пятна от вина Сразу присыпать солью. Дать высохнуть, затем почистить и пропылесосить. Пятно от белого вина промойте водным раствором метилового спирта (3 части спирта, 1 часть воды), высушите, промойте раствором мягкого мыла с водой и высушите. Пятна от красного вина отмываются… белым вином! Затем все так же, как с пятном от белого вина (это проще). 3
3 Пятна крови Если кровь еще не успела засохнуть, ее легко смыть холодной (!) водой. Засохшую кровь можно свести раствором таблетки аспирина в стакане воды. Также можно после помыть с водой и хозяйственным мылом. Если пятно засохло, помойте раствором холодной воды с солью (1 ст.л. на литр). Также подходит перекись водорода на ватке (обязательно проверяйте на кусочке ткани, который не видно). Иногда может помочь зубная паста, но не на всех видах ткани.
4 Пятна от ручки, фломастера, карандашей Удаляются специальным мебельным шампунем. Пятно от воскового карандаша можно свести, положив рыхлую бумагу и прогладив ее утюгом, меняя бумагу (или салфетку). Обычные следы карандашей можно отмыть горячей водой с жидкостью для мытья посуды. Помочь может также ацетон, спирт, но не на всех видах обивки. Плохо сводит с ткани ручку лимонный сок, лак для волос — может испортить тканную обивку.
5 Жирные пятна Свежие пятна лучше сразу засыпать солью (или картофельным крахмалом, мелом, тальком) и менять ее несколько раз. Можно прогладить утюгом через тряпочку. Жиры также растворяют следующие вещества: бензин, эфир, ацетон, спирт, скипидар очищенный. Один из растворителей можно смешать с тальком или крахмалом и положить тряпочку на пятно. Но нельзя наносить эти средства непосредственно на ткань дивана (только на тряпочку) и в нужным пропорциях, иначе можно просто испортить диван.
6 Пятна зеленки, йода Для кожаных диванов: смесь стирального порошка и нашатырного спирта. Но предпочтительней пользоваться спецсредствами. Также советуют капнуть на пятно отбеливатель и затем потереть щеткой, либо раствор аммиака (10%).
7 Пятна краски Акриловые краски легко отмыть холодной водой с хоз. мылом или растворителем акриловых красок. Масляные краски сводятся растворителем для красок. Обязательно проверяйте на другом таком же кусочке ткани! (Ацетон может увеличить пятно.)
8 Пятна от кофе Вымыть мягким мылом или теплой соленой водой, высушить, прикладывая мягкую тряпочку.
9 Пятно клея Если клей ПВА — положите очень мокрую тряпку на пятно и подержите, клей размякнет и его можно будет оттереть. Другие виды клея: размочить клей ваткой с Антиклеем (продается в тюбиках как клей).
10 Пятно от воска Через бумагу или тряпочку прогладить утюгом на слабом режиме, затем аккуратно соскоблить. Если останется пятно, посыпать мелом или тальком и снова прогладить. Еще лучше применить специальный пятновыводитель. На плюше и бархате пятна удаляют спиртом или скипидаром, но не гладят, чтобы не испортить ворса ткани.
11 Жвачка на диване Лед в пакете положить на жвачку, когда затвердеет — отчистить. Протереть тканью, смоченное в метиловом спирте, накрыть чистой сухой тряпочкой и дать высохнуть.
12 Фруктовые пятна Фруктовые соки раствором из аммиака и белого уксуса (1:1), джем и варенье можно помыть мыльным раствором с уксусом. Также мопогает раствор из смеси аммиака и уксуса.
13 Пятна губной помады Тряпочкой, смоченной в нашатырном спирте (скипидаре) протереть пятно, положить сверху сухую тряпку или салфетку и прогладить на слабой температуре. Поможет также смесь лимона и соды (поллимона и немного соды) нанести на пятно, дать высохнуть и очистить щеткой.
14 Пятна от шоколада Выводятся мыльным раствором.
15 Пивное пятно Сразу как следует промокнуть, высушить, затем обработать 1-2 ст. л. белого уксуса на 1 литр воды.
16 Пятна от сладких напитков, молока, кетчупа Сразу замыть теплой водой.
17 Пятна чая Раствор уксуса или пенно-моющее средство.
18 Застарелые пятна Засыпать содой, через 15 минут протереть, затем развести раствор из одной чайной ложки уксуса и четырех столовых ложек воды. Можно вначале залить раствором, сверху засыпать соду. Весь диван можно вымыть этим же раствором, чтобы обновить цвет и убрать мелкие пятнышки.
19 Пятно от фукорцина Народное средство: смешать пополам зубной порошок со спиртом, нанести на пятно, дать высохнуть, пропылесосить. Фукорцин обесцвечивается при обработке пятна раствором сульфита натрия. Но его нельзя оставлять на ткани! Нужно обязательно застирать или нейтрализовать (особенно кислые растворы) раствором соды.
20 Пятна от воды Намочить влажной салфеткой, а затем сушить от центра к краям феном, круговыми движениями, при этом края пятна надо постоянно протирать влажной салфеткой.
21 Пятна от чернил Некоторые виды чернил выводятся соком помидоров, спиртом, денатуратом. Но лучше не экспериментировать и приобрести специальное средство.
22 yes2 ok

http://bar-guzin.com/post398562288/

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
-Человек_в_Шляпе-

Таблица умножения

Понедельник, 19 Сентября 2016 г. 21:15 (ссылка)



Преподаватель математики Екатерина Кунина рассказала AdMe.ru, как освоить таблицу умножения, не отбирая у детей лето. Такой метод упростит изучение, подарит знания и спасёт школьный дневник.


Вы же наверняка не раз слышали мнение, что уровень математического образования падает.


Когда мои дети учились во втором классе, я отчетливо поняла, почему падает уровень математического образования в школе. Именно во втором классе, при закладке фундамента математического образования, возникает такая гигантская невосполнимая дыра.


Главная проблема — в таблице умножения. Посмотрите на тетради в клетку, которые есть у ваших детей-школьников.


Я долго ходила по магазинам в поисках тетрадей. И все равно на всех — вот такая картина:


 



4384049_1551968_original (700x595, 183Kb)




Есть тетради еще хуже (для старшеклассников), на которых таблицы умножения нет, а есть куча бессмысленных формул.


Ну, так чем же эта тетрадь плоха? Ничего не подозревающий родитель видит, что на тетради таблица умножения. Вроде, всю жизнь на тетрадях была таблица умножения. Что не так-то?


А проблема как раз в том, что на тетради НЕ таблица умножения.


Таблица умножения, дорогие мои читатели, это вот:


Читать далее...
Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
Ксения_Дуплинская

таблицы Русский язык

Четверг, 08 Сентября 2016 г. 05:47 (ссылка)




 




























































































































Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
Levkoj

Таблица умножения для младших школьников

Понедельник, 06 Сентября 2016 г. 02:40 (ссылка)

Это цитата сообщения Хьюго_Пьюго_рукоделие Оригинальное сообщение

таблица умножения для младших школьников




таблица умножения для младших школьников 



автор статьи  kukina_kat 

Рё (700x595, 471Kb)

 Посмотрите на тетради в клетку, которые есть у ваших детей-школьников.

Я долго-долго ходила по магазинам в поисках тетрадей. И все равно, на всех -- вот такая картина 

Есть тетради еще хуже (для старшеклассников), на которых таблицы умножения нет, а есть куча бессмысленных формул.

Читать далее...
Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
lenov_ru

Final Shot v 1.0.7 » Клуб пользователей планшетов на ANDROID / Lenovo IdeaTab A2109 8GB / Samsung Galaxy Tab 2 7.0 / Asus Transformer TF700T / NVIDIA Tegra 3

Суббота, 03 Сентября 2016 г. 05:57 (ссылка)
lenov.ru/games/26254-final-...v-107.html


Final Shot - многопользовательский шутер от первого лица с красивой графикой и весьма динамичным геймплеем. Качественная картинка, многочисленное оружие, карты, классы персонажей и другие ос

Комментарии (0)КомментироватьВ цитатник или сообщество
SoftLabirint

ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus) » SoftLabirint.Ru: Скачать бесплатно и без регистрации - Самые Популярные Новости Интернета

Суббота, 27 Августа 2016 г. 15:16 (ссылка)
softlabirint.ru/mobile/2437...tirus.html


ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus)

ABBYY FineScanner – ваш карманный сканер для любых документов от лидера OCR – рынка! Забудьте о настольном сканере навсегда. FineScanner - реальная альтернатива - создает электронные копии документов в форматах PDF и JPEG и распознает печатный текст на сканах (OCR) с сохранением форматирования и выгрузкой результатов в 12 популярных форматов, включая Word, Excel, Power Point, docx, xls, pdf.



Оцифруйте что угодно при помощи вашего смартфона или планшета - документы, чеки, рецепты, заметки, статьи, изображения, диаграммы, таблицы, слайды презентаций, объявления и даже рекламные щиты на улице и получайте электронные копии в отличном качестве. FineScanner - идеальный инструмент для оцифровки, который всегда с собой. Он одинаково полезен для бизнесменов, студентов, научных сотрудников, преподавателей и простых обывателей.



Еще одна интересная особенность приложения – технология BookScan, благодаря которой можно легко и быстро сканировать книги. Она автоматически разделяет сфотографированный разворот книги на две страницы и делает идеальную сканерную копию, которую можно распознать и получить редактируемый файл.



С ABBYY FineScanner вы можете:

• Получать электронные копии любых печатных или рукописных бумаг и сохранять их в удобном формате - JPEG или PDF.

• Распознавать печатные тексты (OCR) на сканах документов на 193 языках (включая латиницу, кириллицу и CJK) с выбором 12 форматов для результатов (включая docx, pdf, txt) и сохранением форматирования документа (списки, таблицы, заголовки) (доступно в премиум-аккаунте, требуется интернет).

• Создавать копии как небольших (1-2 страницы), так и объемных многостраничных документов без дополнительных усилий.

• Делать минимум движений и получать максимум результата. Авто-захват удаляет ненужные поля вокруг листа, чтобы не пришлось обрезать изображение вручную, а встроенные фильтры позволяют сохранить изображение в черно-белом, сером или цветном варианте – наиболее подходящим для печати и пересылки.

• Удобно хранить, помечать тегами и легко искать документы в приложении.

• Экспортировать сканы куда и как угодно –по email, в мессенджеры, в ваше любимое облачное хранилище - Google.Drive, Box, Яндекс.Диск, Evernote, Dropbox, Facebook и так далее .



Что нового в данной версии программы:

Now first recognition is free! Try our best OCR for your contracts, books, leaflets and convert them to a fully formatted Word, Excel or a PDF document.

Better experience for Android tablets.

Better support for Android 6 runtime permissions.

Tags are easier to use.

 



ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus) ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus) ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus) ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus)






Информация о программе

Год выпуска: 2016

Разработчик: ABBYY

ОС: Android 4.0.3 или более поздняя

Root: не требуется

Язык Интерфейса: Русский | Multilanguage

Статус: Premium features unlocked!

Размер: 15,6 MB



Скачать: ABBYY FineScanner Premium 1.5.108 (Android/Multi/Rus)



Скачать | Download | TurboBit.net

http://turbobit.net/4c99i04b0zd7/FineScanner_1.5.108.apk.html



Скачать | Download | HitFile.net

http://www.hitfile.net/NdCxRRo/FineScanner_1.5.108.apk.html



Скачать | Download | Файлообменник.рф

http://файлообменник.рф/1kl8ebg5189o/FineScanner_1.5.108.apk.html



Скачать | Download | BornCash.org

http://borncash.org/load/1734001377&amp;name=FineScanner_1.5.108.apk



Скачать | Download | StartFiles.org

http://startfiles.org/load/1734001377&amp;name=FineScanner_1.5.108.apk



Скачать | Download | GoldFiles.org

http://goldfiles.org/load/1734001377&amp;name=FineScanner_1.5.108.apk



Скачать | Download | File-Space.org

http://file-space.org/files/get/n0_xqqgK0F/finescanner-1.5.108.apk.html



Скачать | Download | DepFile.com

http://kyc.pm/tyVy6mxUz/FineScanner_1.5.108.apk



Подписка на новости сайта…

http://feeds.feedburner.com/Soft-Labirint

http://feeds.feedburner.com/Soft-Labirint?format=xml

https://feedburner.google.com/fb/a/mailverify?uri=Soft-Labirint

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
kseniasamohina

Как автоматизировать процесс написания диссертации

Суббота, 20 Августа 2016 г. 18:42 (ссылка)
md-eksperiment.org/post/201...issertacii


Если писать диссертацию "в лоб" без вспомогательных средств, то неизбежно возникают проблемы с нумерацией элементов (рисунков, таблиц, формул, определений и т.д.) и ссылками на них.

Комментарии (0)КомментироватьВ цитатник или сообщество
Понтифик_Иванов

Как автоматизировать процесс написания диссертации

Суббота, 20 Августа 2016 г. 17:18 (ссылка)
md-eksperiment.org/post/201...issertacii

Если писать диссертацию "в лоб" без вспомогательных средств, то неизбежно возникают проблемы с нумерацией элементов (рисунков, таблиц, формул, определений и т.д.) и ссылками на них.
Комментарии (0)КомментироватьВ цитатник или сообщество
Максимыч-

Таблицы, которые не мешает запомнить.

Среда, 17 Августа 2016 г. 14:47 (ссылка)




Таблицы, которые не мешает запомнить.


Рамка Makсимыча

Метки:   Комментарии (2)КомментироватьВ цитатник или сообщество
anop

Футболки с рисунком таблицы сивцева

Пятница, 07 Августа 2015 г. 09:20 (ссылка)

Футболки с рисунком таблицы сивцева.


Читать далее
Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
ivapet

Новый стандарт украинского образования: теперь школьникам обязательно уметь считать только до пяти

Суббота, 06 Августа 2016 г. 13:45 (ссылка)
infopolk.ru/1/U/events/8187...9efd14bb02

Новый стандарт украинского образования: теперь школьникам обязательно уметь считать только до пяти


Министерство образования и науки Украины утвердило изменения в учебные программы для 1-4 классов ...

Комментарии (0)КомментироватьВ цитатник или сообщество
Onem

Министерство образования Украины решило отменить изучение таблицы сложения и вычитания в 1-м и 2-м классах

Четверг, 05 Августа 2016 г. 03:09 (ссылка)
infopolk.ru/1/U/events/8180...00fc74687c

Министерство образования Украины решило отменить изучение таблицы сложения и вычитания в 1-м и 2-м классах


Украинская система образования приходит в порядок! Отныне решением Министерства образования Украины будет отменено изучение таблицы сложения и вычитания в полном объеме в первом и втором кла ...

Комментарии (0)КомментироватьВ цитатник или сообщество
Anna-Victoria

Фишки в Excel: преобразование строк в столбцы

Вторник, 02 Августа 2016 г. 12:54 (ссылка)
nagel-heart.ru/izuchaem-ms-...v-stolbcyi


При создании таблиц иногда необходимо данные из строки преобразовать в данные столбца. Данный процесс называется транспонирование. В программе MS Excel есть возможность быстро осуществить эту функцию. Более подробно о том как это сделать читайте в статье "Фишки в Excel: преобразование строк в столбцы"



Транспонирование данных

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество
Anna-Victoria

Быстро заполняем названия месяцев в Excel

Понедельник, 01 Августа 2016 г. 20:14 (ссылка)
nagel-heart.ru/izuchaem-ms-...ev-v-excel


Продолжаем осваивать программу MS Excel. На этот раз знакомимся с тем как заполнять быстро ячейки названиями месяцев.



Быстро заполняем названия месяцев в Excel



заполнение таблиц excel

Метки:   Комментарии (0)КомментироватьВ цитатник или сообщество

Следующие 30  »

<таблицы - Самое интересное в блогах

Страницы: [1] 2 3 ..
.. 10

LiveInternet.Ru Ссылки: на главную|почта|знакомства|одноклассники|фото|открытки|тесты|чат
О проекте: помощь|контакты|разместить рекламу|версия для pda